<!DOCTYPE html> <!--[if lt IE 7 ]><html class="no-js ie ie6" lang="en-US"> <![endif]--> <!--[if IE 7 ]><html class="no-js ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8 ]><html class="no-js ie ie8" lang="en-US"> <![endif]--> <!--[if (gte IE 9)|!(IE)]><!--><html class="no-js" lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width"><link media="all" href="https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_1722e84660ac9ed80bc57aeaa6fc95fd.css" rel="stylesheet" /><link media="screen" href="https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_c7e633e134e75754432be9ad99ff79a9.css" rel="stylesheet" /><title>BMX Racing on a Small Budget - bmxultra.com</title><link rel="pingback" href="https://bmxultra.com/xmlrpc.php"> <script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script> <link href="https://fonts.googleapis.com/css?family=Open+Sans:400,300,600,700,300italic,400italic,600italic,700italic" rel="stylesheet" type="text/css"> <!--[if lt IE 9]> <script src="https://html5shiv.googlecode.com/svn/trunk/html5.js"></script> <script src="https://bmxultra.com/wp-content/themes/feather12/js/mediaqueries.js"></script> <![endif]--><link rel="dns-prefetch" href="https://static.hupso.com/share/js/counters.js"><link rel="preconnect" href="https://static.hupso.com/share/js/counters.js"><link rel="preload" href="https://static.hupso.com/share/js/counters.js"><meta property="og:image" content="https://bmxultra.com/wp-content/uploads/2020/02/20200216_sunbury-open_img_6507-300x200.jpg"/><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://bmxultra.com/news/bmx-racing-on-a-small-budget/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="BMX Racing on a Small Budget - bmxultra.com" /><meta property="og:description" content="There is no doubt that BMX Racing can be an expensive pastime, but it doesn&#8217;t have to be. People get into BMX..." /><meta property="og:url" content="https://bmxultra.com/news/bmx-racing-on-a-small-budget/" /><meta property="og:site_name" content="bmxultra.com" /><meta property="article:publisher" content="https://www.facebook.com/bmxultra/" /><meta property="article:published_time" content="2020-06-12T08:14:56+00:00" /><meta property="og:image" content="https://bmxultra.com/wp-content/uploads/2020/02/20200216_sunbury-open_img_6507.jpg" /><meta property="og:image:width" content="1800" /><meta property="og:image:height" content="1200" /><meta property="fb:app_id" content="559294064204019" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@bmxultra" /><meta name="twitter:site" content="@bmxultra" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://bmxultra.com/#website","url":"https://bmxultra.com/","name":"bmxultra.com","description":"","potentialAction":[{"@type":"SearchAction","target":"https://bmxultra.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://bmxultra.com/news/bmx-racing-on-a-small-budget/#primaryimage","inLanguage":"en-US","url":"https://bmxultra.com/wp-content/uploads/2020/02/20200216_sunbury-open_img_6507.jpg","width":1800,"height":1200},{"@type":"WebPage","@id":"https://bmxultra.com/news/bmx-racing-on-a-small-budget/#webpage","url":"https://bmxultra.com/news/bmx-racing-on-a-small-budget/","name":"BMX Racing on a Small Budget - bmxultra.com","isPartOf":{"@id":"https://bmxultra.com/#website"},"primaryImageOfPage":{"@id":"https://bmxultra.com/news/bmx-racing-on-a-small-budget/#primaryimage"},"datePublished":"2020-06-12T08:14:56+00:00","dateModified":"2020-06-12T08:14:56+00:00","author":{"@id":"https://bmxultra.com/#/schema/person/0b1506325b33e7c55c7b8c0503f8764e"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://bmxultra.com/news/bmx-racing-on-a-small-budget/"]}]},{"@type":["Person"],"@id":"https://bmxultra.com/#/schema/person/0b1506325b33e7c55c7b8c0503f8764e","name":"bmxultra","image":{"@type":"ImageObject","@id":"https://bmxultra.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/747bbf2907892d65063279e3f7317d59?s=96&d=mm&r=g","caption":"bmxultra"}}]}</script> <link rel='dns-prefetch' href='//www.googletagmanager.com' /><link rel="alternate" type="application/rss+xml" title="bmxultra.com &raquo; Feed" href="https://bmxultra.com/feed/" /><link rel="alternate" type="application/rss+xml" title="bmxultra.com &raquo; Comments Feed" href="https://bmxultra.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="bmxultra.com &raquo; BMX Racing on a Small Budget Comments Feed" href="https://bmxultra.com/news/bmx-racing-on-a-small-budget/feed/" /> <script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script> <script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-732058-1' async></script> <script type='text/javascript'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-732058-1', {"anonymize_ip":true} );</script> <link rel='https://api.w.org/' href='https://bmxultra.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://bmxultra.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://bmxultra.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://bmxultra.com/?p=17172' /><link rel="alternate" type="application/json+oembed" href="https://bmxultra.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbmxultra.com%2Fnews%2Fbmx-racing-on-a-small-budget%2F" /><link rel="alternate" type="text/xml+oembed" href="https://bmxultra.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbmxultra.com%2Fnews%2Fbmx-racing-on-a-small-budget%2F&#038;format=xml" /><meta name="generator" content="Site Kit by Google 1.9.0" /><link rel="shortcut icon" href="https://bmxultra.com/wp-content/uploads/2013/07/favicon1.png"><meta name="robots" content="noodp,noydir">  <script type="text/javascript">var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';</script> <script type="text/javascript">var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-732058-1']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = 'https://bmxultra.com/wp-content/uploads/cached-scripts/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();</script> <noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head><body data-rsssl=1 class="post-template-default single single-post postid-17172 single-format-standard mobile-sidebar"><div id="wrap"><header id="header"><div id="header-inner" class="container fix"><h1 id="logo"> <a href="https://bmxultra.com"><img src="https://bmxultra.com/wp-content/themes/feather12/img/bmxultra40.png" alt="bmxultra.com" width="279" height="40" /></a></h1><nav id="header-nav" class="fix"><ul id="nav" class="menu"><li id="menu-item-2032" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-2032"><a href="https://bmxultra.com/">Home</a></li><li id="menu-item-2045" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-2045"><a href="https://bmxultra.com/category/news/">News</a><ul class="sub-menu"><li id="menu-item-8268" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8268"><a href="https://bmxultra.com/category/freestyle-bmx/">Freestyle BMX</a></li><li id="menu-item-4752" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4752"><a href="https://bmxultra.com/news-archive/">News Archive</a></li></ul></li><li id="menu-item-2200" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2200"><a href="https://bmxultra.com/category/photos/">Photos</a><ul class="sub-menu"><li id="menu-item-8087" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8087"><a href="https://bmxultra.com/category/video/">Video</a></li></ul></li><li id="menu-item-2041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2041"><a href="https://bmxultra.com/category/review/">Reviews</a><ul class="sub-menu"><li id="menu-item-8011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8011"><a href="https://bmxultra.com/category/review/complete-bikes/">Complete Bikes</a></li><li id="menu-item-8007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8007"><a href="https://bmxultra.com/category/review/frames/">Frames</a></li><li id="menu-item-8010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8010"><a href="https://bmxultra.com/category/review/fork-review/">Forks</a></li><li id="menu-item-8008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8008"><a href="https://bmxultra.com/category/review/bars/">Handlebars</a></li><li id="menu-item-8009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8009"><a href="https://bmxultra.com/category/review/headstem/">Headstems</a></li><li id="menu-item-8012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8012"><a href="https://bmxultra.com/category/review/brakes-review/">Brakes</a></li><li id="menu-item-8013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8013"><a href="https://bmxultra.com/category/review/cranks-review/">Cranks</a></li><li id="menu-item-8014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8014"><a href="https://bmxultra.com/category/review/grips-review/">Grips</a></li><li id="menu-item-8015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8015"><a href="https://bmxultra.com/category/review/hubs-review/">Hubs</a></li><li id="menu-item-8016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8016"><a href="https://bmxultra.com/category/review/pedals/">Pedals</a></li><li id="menu-item-8017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8017"><a href="https://bmxultra.com/category/review/rims-review/">Rims</a></li><li id="menu-item-8018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8018"><a href="https://bmxultra.com/category/review/seat-review/">Seats</a></li><li id="menu-item-8019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8019"><a href="https://bmxultra.com/category/review/tires-review/">Tires</a></li><li id="menu-item-8006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8006"><a href="https://bmxultra.com/category/review/gear/">Race Clothing</a></li><li id="menu-item-8220" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8220"><a href="https://bmxultra.com/category/review/clothing-review/">Casual Clothing</a></li><li id="menu-item-2040" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2040"><a href="https://bmxultra.com/category/review/lifestyle/">Lifestyle</a></li></ul></li><li id="menu-item-3171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3171"><a href="https://bmxultra.com/category/interview/">Interviews</a></li><li id="menu-item-2658" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2658"><a href="https://bmxultra.com/gear-calculator/">Gear Calculator</a><ul class="sub-menu"><li id="menu-item-30217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30217"><a href="https://bmxultra.com/gear-calculator/">Gear Calculator</a></li><li id="menu-item-30197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30197"><a href="https://bmxultra.com/gear-calculator/revlookup/">Reverse Lookup Gear Chart</a></li><li id="menu-item-2657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2657"><a href="https://bmxultra.com/gear-chart/">Standard Gear Chart</a></li><li id="menu-item-28112" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28112"><a href="https://bmxultra.com/rennen-bmx-decimal-gear-chart/">Decimal Gear Chart</a></li><li id="menu-item-8121" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8121"><a href="https://bmxultra.com/gearcalc/">BMX Gear Calculator App</a></li></ul></li><li id="menu-item-2042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2042"><a href="https://bmxultra.com/links/">Links</a><ul class="sub-menu"><li id="menu-item-8120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-8120"><a href="https://bmxultra.com/bsx/">BSX</a><ul class="sub-menu"><li id="menu-item-30414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30414"><a href="https://bmxultra.com/bsx2019/">BSX2019</a></li><li id="menu-item-28152" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28152"><a href="https://bmxultra.com/bsx/bsx2018-charity-event/">BSX2018</a></li><li id="menu-item-25931" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25931"><a href="https://bmxultra.com/bsx/bsx2017/">BSX2017</a></li><li id="menu-item-21496" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21496"><a href="https://bmxultra.com/bsx2016-bmx-charity-event/">BSX2016</a></li><li id="menu-item-21497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21497"><a href="https://bmxultra.com/bsx/bsx2015/">BSX2015</a></li><li id="menu-item-14152" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14152"><a href="https://bmxultra.com/bsx/bsx2014/">BSX2014</a></li></ul></li><li id="menu-item-2053" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2053"><a href="https://bmxultra.com/team/">Team</a></li><li id="menu-item-16621" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16621"><a href="https://bmxultra.com/the-history-of-australian-bmx-racing/">History Of Australian BMX Racing</a></li><li id="menu-item-8150" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8150"><a href="https://bmxultra.com/dirt-2/">Dirt Designs</a></li><li id="menu-item-8155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8155"><a href="https://bmxultra.com/contact-us/">Contact Us</a></li><li id="menu-item-10026" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10026"><a href="https://bmxultra.com/forum">bmxultra.com forum</a><ul class="sub-menu"><li id="menu-item-8168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8168"><a href="/smf">The old forum</a></li></ul></li><li id="menu-item-11072" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11072"><a href="https://bmxultra.com/site-map/">Site Map</a></li></ul></li></ul></nav></div></header><div id="subheader"><div class="container fix"><div id="subheader-search" class="fix"><form method="get" id="searchform" action="https://bmxultra.com/"><div> <input type="text" id="s" name="s" onblur="if(this.value=='')this.value='Enter your search...';" onfocus="if(this.value=='Enter your search...')this.value='';" value="Enter your search..." /></div></form></div><ul class="ad"><li id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><a href="https://t.cfjump.com/45419/b/155936" referrerpolicy="no-referrer-when-downgrade" rel="nofollow noindex" onmousedown="this.rel = 'nofollow noindex';"><img style="border: none; vertical-align: middle;" alt="" referrerpolicy="no-referrer-when-downgrade" src="https://t.cfjump.com/45419/a/155936" /></a></div></li></ul></div></div><div class="pagecontainer container fix "><div id="page-title"><h2>News</h2></div><div id="content-part"><article id="entry-17172" class="entry fix post-17172 post type-post status-publish format-standard has-post-thumbnail hentry category-news"><div class="pad fix"><header class="fix"><h1 class="entry-title"> BMX Racing on a Small Budget</h1><ul class="entry-meta fix"><li class="entry-date">June 12th, 2020</li><li class="entry-author"><a href="https://bmxultra.com/author/admin/" title="Posts by bmxultra" rel="author">bmxultra</a></li><li class="entry-comments"><a href="https://bmxultra.com/news/bmx-racing-on-a-small-budget/#respond">0</a></li></ul></header><div class="clear"></div><div class="text"><p>There is no doubt that BMX Racing can be an expensive pastime, but it doesn&#8217;t have to be. People get into BMX racing for many reasons; fun, fitness, socialising, a challenge, it&#8217;s something the whole family can get involved in or just for something different. The cost of BMX racing can increase significantly as you progress from local to state events and beyond.</p><p>To me BMX racing at any level is fun, which is key, and I have to keep reminding myself of that. Do I need to race at a national championship event to have fun? The answer is simple, no. If you live close to a race track you can enjoy your BMX racing without the extra costs of travel, accommodation and so on.</p><p>The great thing about BMX racing at the most basic level is that it&#8217;s a very affordable sport. Practice nights, coaching and club races are the ongoing costs but are comparable to other sports.</p><p>In Australia you can race at club level without the requirement of a transponder, although it&#8217;s only a matter of time before transponders are required for local racing too. Clothing requirements are a little more relaxed at this level too, anything above club level will require race pants. Even though I have seen race pants that wouldn&#8217;t have half the durability or strength of jeans or even track pants for that matter, but that&#8217;s an argument for another time. Entry fees are far lower at this level and generally you don&#8217;t have to travel as far.</p><p>While club level racing might not be for everyone, some BMXers chase greater glory, it certainly is a great way to get involved and develop your skills. If you don&#8217;t have a bike or helmet to get started, don&#8217;t worry, your local track should have you covered. No matter how you look at it it&#8217;s still BMX Racing and it can be a whole lot of fun. It might be a little while before clubs start opening up for racing, but it&#8217;s a good time to jump on Google or Social Media and find your local track.</p><p>&nbsp;</p><p>&nbsp;</p><div style="padding-bottom:10px; padding-top:10px;" class="hupso-share-buttons"><a class="hupso_counters" href="https://www.hupso.com/share/"><img src="https://static.hupso.com/share/buttons/dot.png" style="border:0px; padding-top:2px; float:left;" alt="Share Button"/></a><script type="text/javascript">var hupso_services_c=new Array("twitter","facebook_like","facebook_send","google");var hupso_counters_lang = "en_US";var hupso_image_folder_url = "";var hupso_twitter_via="bmxultra";var hupso_url_c="";var hupso_title_c="BMX%20Racing%20on%20a%20Small%20Budget";</script><script type="text/javascript" src="https://static.hupso.com/share/js/counters.js"></script></div><div class="clear"></div></div><div class="post-nav"><div class="prev"> &laquo; <a href="https://bmxultra.com/news/ecitv-answer-bmx-show-us-ya-bike-competition/" rel="prev">ECITV/Answer BMX Show Us Ya Bike Competition</a></div> |<div class="next"></div></div><p class="entry-category"><span>Posted in:</span> <a href="https://bmxultra.com/category/news/" rel="category tag">News</a></p></div></article></div><div id="sidebar" class="sidebar-right"><ul><li id="wp_category_post_list_itg-2" class="widget widget_wp_category_post_list_itg"><h3 class="widget-title"><span>Other News</span></h3><ul class="wp-cpl-widget wp-cpl-theme-no"><li class="wp-cpl wp-cpl-even"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/bmx-racing-on-a-small-budget/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2020/02/20200216_sunbury-open_img_6507-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" srcset="https://bmxultra.com/wp-content/uploads/2020/02/20200216_sunbury-open_img_6507-50x33.jpg 50w, https://bmxultra.com/wp-content/uploads/2020/02/20200216_sunbury-open_img_6507-300x200.jpg 300w, https://bmxultra.com/wp-content/uploads/2020/02/20200216_sunbury-open_img_6507-640x427.jpg 640w, https://bmxultra.com/wp-content/uploads/2020/02/20200216_sunbury-open_img_6507-768x512.jpg 768w, https://bmxultra.com/wp-content/uploads/2020/02/20200216_sunbury-open_img_6507-1536x1024.jpg 1536w, https://bmxultra.com/wp-content/uploads/2020/02/20200216_sunbury-open_img_6507-708x472.jpg 708w, https://bmxultra.com/wp-content/uploads/2020/02/20200216_sunbury-open_img_6507.jpg 1800w" sizes="(max-width: 50px) 100vw, 50px" /></a></span></span><a href="https://bmxultra.com/news/bmx-racing-on-a-small-budget/" title="Permalink to: BMX Racing on a Small Budget" target="_self">BMX Racing on a Small Budget</a></li><li class="wp-cpl wp-cpl-odd"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/ecitv-answer-bmx-show-us-ya-bike-competition/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2020/06/wheatie-2-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" /></a></span></span><a href="https://bmxultra.com/news/ecitv-answer-bmx-show-us-ya-bike-competition/" title="Permalink to: ECITV/Answer BMX Show Us Ya Bike Competition" target="_self">ECITV/Answer BMX Show Us Ya Bike Competition</a></li><li class="wp-cpl wp-cpl-even"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/ecitv-100-bmx-racing-show-episode-12-this-notes-for-you/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2020/06/ecitv-ep12-feature-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" /></a></span></span><a href="https://bmxultra.com/news/ecitv-100-bmx-racing-show-episode-12-this-notes-for-you/" title="Permalink to: ECITV - 100% BMX Racing Show: Episode 12 "This Note's for You"" target="_self">ECITV - 100% BMX Racing Show: Episode 12 "This Note's for You"</a></li><li class="wp-cpl wp-cpl-odd"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/vans-australia-end-of-season-sale/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2020/06/vans-end-of-season-2020-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" /></a></span></span><a href="https://bmxultra.com/news/vans-australia-end-of-season-sale/" title="Permalink to: Vans Australia End of Season Sale" target="_self">Vans Australia End of Season Sale</a></li><li class="wp-cpl wp-cpl-even"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/ecitv-dozers-dad-joke-battle-bias-vs-collins/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2020/06/ecitv-dad-joke-battle-bias-vs-collins-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" /></a></span></span><a href="https://bmxultra.com/news/ecitv-dozers-dad-joke-battle-bias-vs-collins/" title="Permalink to: ECITV Dozer's Dad Joke Battle - Bias Vs Collins" target="_self">ECITV Dozer's Dad Joke Battle - Bias Vs Collins</a></li><li class="wp-cpl wp-cpl-odd"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/vees-new-tires-speedbooster-elite-and-os20-speedbooster/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2020/06/vee-speedbooster-elite-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" /></a></span></span><a href="https://bmxultra.com/news/vees-new-tires-speedbooster-elite-and-os20-speedbooster/" title="Permalink to: Vee's New Tires: Speedbooster Elite and OS20 Speedbooster" target="_self">Vee's New Tires: Speedbooster Elite and OS20 Speedbooster</a></li><li class="wp-cpl wp-cpl-even"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/ecitv-100-bmx-racing-show-episode-11-jesus-built-my-hot-rod/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2020/05/ecitv-ep-11-feature-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" /></a></span></span><a href="https://bmxultra.com/news/ecitv-100-bmx-racing-show-episode-11-jesus-built-my-hot-rod/" title="Permalink to: ECITV - 100% BMX Racing Show: Episode 11 "Jesus Built My Hot Rod"" target="_self">ECITV - 100% BMX Racing Show: Episode 11 "Jesus Built My Hot Rod"</a></li><li class="wp-cpl wp-cpl-odd"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/pre-order-your-supercross-90s-jersey/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2020/05/supercross-bmx-90s-jersey-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" srcset="https://bmxultra.com/wp-content/uploads/2020/05/supercross-bmx-90s-jersey-50x33.jpg 50w, https://bmxultra.com/wp-content/uploads/2020/05/supercross-bmx-90s-jersey-300x200.jpg 300w, https://bmxultra.com/wp-content/uploads/2020/05/supercross-bmx-90s-jersey-640x427.jpg 640w, https://bmxultra.com/wp-content/uploads/2020/05/supercross-bmx-90s-jersey-768x512.jpg 768w, https://bmxultra.com/wp-content/uploads/2020/05/supercross-bmx-90s-jersey-1536x1024.jpg 1536w, https://bmxultra.com/wp-content/uploads/2020/05/supercross-bmx-90s-jersey-708x472.jpg 708w, https://bmxultra.com/wp-content/uploads/2020/05/supercross-bmx-90s-jersey.jpg 2000w" sizes="(max-width: 50px) 100vw, 50px" /></a></span></span><a href="https://bmxultra.com/news/pre-order-your-supercross-90s-jersey/" title="Permalink to: Pre-Order Your Supercross 90's Jersey" target="_self">Pre-Order Your Supercross 90's Jersey</a></li><li class="wp-cpl wp-cpl-even"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/answer-bmx-joins-the-ecitv-party/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2020/05/ecitv-answer-numberplate-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" /></a></span></span><a href="https://bmxultra.com/news/answer-bmx-joins-the-ecitv-party/" title="Permalink to: Answer BMX Joins The ECITV Party" target="_self">Answer BMX Joins The ECITV Party</a></li><li class="wp-cpl wp-cpl-odd"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/product-spotlight-vans-sk8-hi-pro-bmx-shoes/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2020/05/vans-sk8-hi-pro-bmx-feature-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" /></a></span></span><a href="https://bmxultra.com/news/product-spotlight-vans-sk8-hi-pro-bmx-shoes/" title="Permalink to: Product Spotlight: Vans Sk8-Hi Pro BMX Shoes" target="_self">Product Spotlight: Vans Sk8-Hi Pro BMX Shoes</a></li></ul></li><li id="text-4" class="widget widget_text"><h3 class="widget-title"><span>Advertisement</span></h3><div class="textwidget"><p><br /> <a href="https://t.cfjump.com/45419/b/155932" referrerpolicy="no-referrer-when-downgrade" rel="nofollow noindex" onmousedown="this.rel = 'nofollow noindex';"><img style="border: none; vertical-align: middle;" alt="" referrerpolicy="no-referrer-when-downgrade" src="https://t.cfjump.com/45419/a/155932" /></a></p><p><a href="https://rizenunlimited.com/" rel="noopener"><img title="Rizen Race Wear" src="https://bmxultra.com/wp-content/uploads/2019/12/rizen-banner-250x250.jpg" alt="Rizen Race Wear" width="220" height="220" /></a></p><p><a href="http://pedalinginnovations.com/?referrer=15" target="_blank" rel="noopener noreferrer"><img title="Pedaling Innovations" src="https://bmxultra.com/wp-content/uploads/2019/08/pedaling-innovations-v3.png" alt="Pedaling Innovations" width="220" height="220" /></a></p><p><a href="http://supercrossbmx.com" target="_blank" rel="noopener noreferrer"><img title="Supercross BMX" src="https://bmxultra.com/wp-content/uploads/2019/08/supercross-2019-220x220.jpg" alt="Supercross BMX" width="220" height="220" /></a></p><p><a href="https://itunes.apple.com/us/app/bmx-gear-calculator/id665859954?mt=8" target="_blank" rel="noopener noreferrer"><img title="bmxultra.com gear calculator for iPhone/iPad" src="https://bmxultra.com/wp-content/uploads/2014/04/bmxultra-bmx-gear-calculator-app-tower-ad-v1_5.jpg" alt="bmxultra.com gear calculator for iPhone/iPad" width="220" height="500" /></a></p></div></li><li id="text-5" class="widget widget_text"><h3 class="widget-title"><span>bmxultra.com Archives</span></h3><div class="textwidget"><p>Are you looking for content from the old bmxultra.com website?</p><p>Don't worry it's not gone. We have just tucked it away for you.</p><p><a href="/archive" class="btn btn-default btn-small">View the archives</a></p></div></li></ul></div></div><div class="clear"></div><footer id="footer" class="fix"><div id="footer-contact"><div class="container fix"><p id="contact-email"><a href="mailto:webmaster@bmxultra.com">webmaster@bmxultra.com</a></p><div class="menu-secondary-navigation-container"><ul id="menu-secondary-navigation" class="menu"><li id="menu-item-8413" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8413"><a href="https://bmxultra.com/contact-us/">Contact Us</a></li><li id="menu-item-8594" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8594"><a href="https://bmxultra.com/bmx-sizing-charts/">BMX Sizing Charts</a></li><li id="menu-item-8411" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8411"><a href="https://bmxultra.com/advertise-with-us/">Advertise With Us</a></li></ul></div></div></div><div id="footer-widgets"><div class="container fix"><li id="text-3" class="widget widget_text"><h3 class="widget-title fix"><span>bmxultra.com Partners</span></h3><div class="textwidget"><div style="text-align: center"> <a href="http://www.alienationbmx.com/" target="_blank" rel="noopener noreferrer"><img src="https://bmxultra.com/wp-content/uploads/2015/09/alienation.png" alt="Alienation BMX" title="Alienation BMX" height="70" width="200" /></a> <a href="http://www.tiogausa.com/" target="_blank" rel="noopener noreferrer"><img src="https://bmxultra.com/wp-content/uploads/2015/09/tiogabmx.png" alt="Tioga BMX" title="Tioga BMX" height="70" width="200" /></a> <a href="http://www.supercrossbmx.com.au/" target="_blank" rel="noopener noreferrer"><img src="https://bmxultra.com/wp-content/uploads/2015/09/supercrossbmx.png" alt="Supercross BMX" title="Supercross BMX" height="70" width="200" /></a> <a href="http://www.profileracing.com/" target="_blank" rel="noopener noreferrer"><img src="https://bmxultra.com/wp-content/uploads/2018/02/profile-logo.png" alt="Profile Racing" title="Profile Racing" height="70" width="200" /></a> <a href="http://www.odigrips.com/" target="_blank" rel="noopener noreferrer"><img src="https://bmxultra.com/wp-content/uploads/2018/02/odi-logo.png" alt="ODI Grips" title="ODI Grips" height="70" width="200" /></a> <a href="https://rizenunlimited.com/" target="_blank" rel="noopener noreferrer"><img src="https://bmxultra.com/wp-content/uploads/2019/12/rizen-logo.png" alt="Rizen Race Wear" title="Rizen Race Wear" height="70" width="200" /></a></div></div></li></div></div><div id="footer-bottom"><div class="container fix"><div class="one-half"><p id="copy">Copyright @2019 bmxultra.com. All rights reserved</p></div><div class="one-half last"> <a id="to-top" href="#"><i class="icon-top"></i></a><ul id="footer-social"><li><a href="http://www.facebook.com/bmxultra" target="_blank"><span class="icon"><img src="https://bmxultra.com/wp-content/themes/feather12/air/modules/social/icons/default/facebook_16.png" alt="Facebook" /></span><span class="icon-title"><i class="icon-pike"></i>Facebook</span></a></li><li><a href="http://www.youtube.com/user/bmxultradotcom" target="_blank"><span class="icon"><img src="https://bmxultra.com/wp-content/themes/feather12/air/modules/social/icons/default/youtube_16.png" alt="YouTube" /></span><span class="icon-title"><i class="icon-pike"></i>YouTube</span></a></li><li><a href="https://twitter.com/bmxultra" target="_blank"><span class="icon"><img src="https://bmxultra.com/wp-content/themes/feather12/air/modules/social/icons/default/twitter_16.png" alt="Twitter" /></span><span class="icon-title"><i class="icon-pike"></i>Twitter</span></a></li></ul></div></div></div></footer></div> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/bmxultra.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"cached":"1"};</script> <script type='text/javascript'>var objectL10n = {"navigate":"Navigate to ..."};</script> <script type='text/javascript'>( 'fetch' in window ) || document.write( '<script src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );
( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://bmxultra.com/wp-content/plugins/gutenberg/vendor/wp-polyfill-url.min.7490158b.js?ver=3.6.4"></scr' + 'ipt>' );
( window.DOMRect ) || document.write( '<script src="https://bmxultra.com/wp-content/plugins/gutenberg/vendor/wp-polyfill-dom-rect.7e21c103.js?ver=3.42.0"></scr' + 'ipt>' );</script> <script type='text/javascript'>( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );</script> <script type='text/javascript'>( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );</script> <script type='text/javascript'>var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};</script> <script type='text/javascript'>jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});</script> <script>jQuery(function($) {
$('a[rel^="fancybox-media"]').prettyPhoto({ social_tools: '<div class="twitter"><iframe allowtransparency="true" frameborder="0" scrolling="no" src="//platform.twitter.com/widgets/tweet_button.html?count=none&amp;url={location_href}" style="border:none; overflow:hidden; width:59px; height:20px;"></iframe></div><div class="facebook"><iframe src="//www.facebook.com/plugins/like.php?href={location_href}&amp;send=false&amp;layout=button_count&amp;width=450&amp;show_faces=false&amp;action=like&amp;colorscheme=light&amp;font&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:50px; height:21px;" allowTransparency="true"></iframe></div>' });
});</script> <script type='text/javascript' src='https://stats.wp.com/e-202024.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.6.1',blog:'76802680',post:'17172',tz:'10',srv:'bmxultra.com'} ]);
	_stq.push([ 'clickTrackerInit', '76802680', '17172' ]);</script> <script defer src="https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_6c4ee63b82870d4bbfc504b586294e46.js"></script></body></html>
<!-- *´¨)
     ¸.•´¸.•*´¨) ¸.•*¨)
     (¸.•´ (¸.•` ¤ Comet Cache is Fully Functional ¤ ´¨) -->

<!-- Cache File Version Salt:       n/a -->

<!-- Cache File URL:                https://bmxultra.com/news/bmx-racing-on-a-small-budget/ -->
<!-- Cache File Path:               /cache/comet-cache/cache/https/bmxultra-com/news/bmx-racing-on-a-small-budget.html -->

<!-- Cache File Generated Via:      HTTP request -->
<!-- Cache File Generated On:       Jun 12th, 2020 @ 5:55 pm UTC -->
<!-- Cache File Generated In:       2.70087 seconds -->

<!-- Cache File Expires On:         Jun 19th, 2020 @ 5:55 pm UTC -->
<!-- Cache File Auto-Rebuild On:    Jun 19th, 2020 @ 5:55 pm UTC -->

<!-- Loaded via Cache On:    Jun 12th, 2020 @ 6:26 pm UTC -->
<!-- Loaded via Cache In:    0.01989 seconds -->