<!DOCTYPE html> <!--[if lt IE 7 ]><html class="no-js ie ie6" lang="en-US"> <![endif]--> <!--[if IE 7 ]><html class="no-js ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8 ]><html class="no-js ie ie8" lang="en-US"> <![endif]--> <!--[if (gte IE 9)|!(IE)]><!--><html class="no-js" lang="en-US"> <!--<![endif]--><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width"> <noscript id="aonoscrcss"></noscript><title>Product Spotlight: Stay Strong Torque PRO Platform Pedals - bmxultra.com</title><link rel="stylesheet" href="https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_f5c5935d3c4581e05c65ffc194cc42a7.css"><link rel="pingback" href="https://bmxultra.com/xmlrpc.php"> <script>document.documentElement.className = document.documentElement.className.replace("no-js","js");</script> <link href="https://fonts.googleapis.com/css?family=Open+Sans:400,300,600,700,300italic,400italic,600italic,700italic" rel="stylesheet" type="text/css"> <!--[if lt IE 9]> <script src="https://html5shiv.googlecode.com/svn/trunk/html5.js"></script> <script src="https://bmxultra.com/wp-content/themes/feather12/js/mediaqueries.js"></script> <![endif]--><meta name='robots' content='index, follow, max-video-preview:-1, max-snippet:-1, max-image-preview:large' /><link rel="dns-prefetch" href="https://static.hupso.com/share/js/counters.js"><link rel="preconnect" href="https://static.hupso.com/share/js/counters.js"><link rel="preload" href="https://static.hupso.com/share/js/counters.js"><meta property="og:image" content="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-300x200.jpg"/><link rel="canonical" href="https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Product Spotlight: Stay Strong Torque PRO Platform Pedals - bmxultra.com" /><meta property="og:description" content="Stay Strong started off as a brand to help raise money and show support for seriously injured Stephen Murray, but it&#8217;s become..." /><meta property="og:url" content="https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/" /><meta property="og:site_name" content="bmxultra.com" /><meta property="article:publisher" content="https://www.facebook.com/bmxultra/" /><meta property="article:published_time" content="2021-05-06T07:22:11+00:00" /><meta property="og:image" content="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x.jpg" /><meta property="og:image:width" content="1000" /><meta property="og:image:height" content="667" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:creator" content="@bmxultra" /><meta name="twitter:site" content="@bmxultra" /><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="bmxultra"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="1 minute"> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://bmxultra.com/#website","url":"https://bmxultra.com/","name":"bmxultra.com","description":"","potentialAction":[{"@type":"SearchAction","target":"https://bmxultra.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/#primaryimage","inLanguage":"en-US","url":"https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x.jpg","contentUrl":"https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x.jpg","width":1000,"height":667},{"@type":"WebPage","@id":"https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/#webpage","url":"https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/","name":"Product Spotlight: Stay Strong Torque PRO Platform Pedals - bmxultra.com","isPartOf":{"@id":"https://bmxultra.com/#website"},"primaryImageOfPage":{"@id":"https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/#primaryimage"},"datePublished":"2021-05-06T07:22:11+00:00","dateModified":"2021-05-06T07:22:11+00:00","author":{"@id":"https://bmxultra.com/#/schema/person/0b1506325b33e7c55c7b8c0503f8764e"},"breadcrumb":{"@id":"https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/"]}]},{"@type":"BreadcrumbList","@id":"https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://bmxultra.com/","url":"https://bmxultra.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/#webpage"}}]},{"@type":"Person","@id":"https://bmxultra.com/#/schema/person/0b1506325b33e7c55c7b8c0503f8764e","name":"bmxultra","image":{"@type":"ImageObject","@id":"https://bmxultra.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/747bbf2907892d65063279e3f7317d59?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/747bbf2907892d65063279e3f7317d59?s=96&d=mm&r=g","caption":"bmxultra"}}]}</script> <link rel='stylesheet' id='wp-block-library-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_aef5a4cea94bf86d564afcee213590f0.css?ver=10.5.4'  media='all' /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style><link rel='stylesheet' id='cpsh-shortcodes-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_eeb616c7d096549b9792359164dafe24.css?ver=1.0.1'  media='all' /><link rel='stylesheet' id='contact-form-7-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_76e12144b6be9bc0a17dd880c5566156.css?ver=5.4.1'  media='all' /><link rel='stylesheet' id='hupso_css-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_9a57d029e8f0e3cef317034a7c341d4d.css?ver=5.7.1'  media='all' /><link rel='stylesheet' id='timeline-main-css-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_99a5b7fea447d5002e205706c3525100.css?ver=5.7.1'  media='all' /><link rel='stylesheet' id='dcsnt-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_6517257c92751d7332b98d6247754bfe.css?ver=5.7.1'  media='all' /><link rel='stylesheet' id='wpbandit-style-advanced-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_a29f4a53ba929d8b182ac51fb014e9e9.css?ver=5.7.1'  media='all' /><link rel='stylesheet' id='wpbandit-custom-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_9690603feeec77e3002fd3f74d287329.css?ver=1.0'  media='all' /><link rel='stylesheet' id='jquery.ui.theme-css'  href='https://bmxultra.com/wp-content/themes/feather12/styles/jquery-ui-1.10.3.custom.min.css?ver=5.7.1'  media='all' /><link rel='stylesheet' id='slb_core-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_47f1feb5aaf7fb422aad353e698138de.css?ver=2.8.1'  media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_1f72f035a731bd41f78502859ae33301.css?ver=9.7'  media='all' /><link rel='stylesheet' id='wp-cpl-base-css-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_e2084da228fbcad27bca996411ecd6d9.css?ver=2.0.3'  media='all' /><link rel='stylesheet' id='wp_cpl_css_0-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_cc97a4a57c6eadbb1a77be407b0fefa1.css?ver=2.0.3'  media='all' /><link rel='stylesheet' id='wp_cpl_css_1-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_8cc99d57d1f80d3a9b7229ab413e5006.css?ver=2.0.3'  media='all' /><link rel='stylesheet' id='wp_cpl_css_2-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_2ff2e554c4e1c3623df5025dcc9daa3c.css?ver=2.0.3'  media='all' /><link rel='stylesheet' id='wp_cpl_css_3-css'  href='https://bmxultra.com/wp-content/cache/autoptimize/css/autoptimize_single_7135042d4f70de96cf09c546e7b783d8.css?ver=2.0.3'  media='all' /> <script type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_15472b1a91b1eabd1d27eb9735cb6516.js?ver=5.7.1' id='timeline-main-js-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/plugins/social-network-tabs/js/jquery.social.media.tabs.1.7.1.min.js?ver=5.7.1' id='dcsnt-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_ec9758d9508e2fd22ddbdc6d5a28f214.js?ver=5.7.1' id='jquery-ui-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/themes/feather12/js/jquery.ui.touch-punch.min.js?ver=5.7.1' id='jquery-touch-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_1e3faa7fc49484964ecae46ca9494f35.js?ver=5.7.1' id='jquery-cookies-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/plugins/google-analyticator/external-tracking.min.js?ver=6.5.4' id='ga-external-tracking-js'></script> <link rel="https://api.w.org/" href="https://bmxultra.com/wp-json/" /><link rel="alternate" type="application/json" href="https://bmxultra.com/wp-json/wp/v2/posts/34232" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://bmxultra.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://bmxultra.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://bmxultra.com/?p=34232' /><link rel="alternate" type="application/json+oembed" href="https://bmxultra.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbmxultra.com%2Fnews%2Fproduct-spotlight-stay-strong-torque-pro-platform-pedals%2F" /><link rel="alternate" type="text/xml+oembed" href="https://bmxultra.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fbmxultra.com%2Fnews%2Fproduct-spotlight-stay-strong-torque-pro-platform-pedals%2F&#038;format=xml" /> <script type="text/javascript">function powerpress_pinw(pinw_url){window.open(pinw_url, 'PowerPressPlayer','toolbar=0,status=0,resizable=1,width=460,height=320');	return false;}</script> <style type="text/css">.tab-twitter,.tab-twitter .dcsmt-btn, li.active.dcsmt-twitter, li.dcsmt-twitter:hover{background-color:#4ec2dc;}.tab-facebook,.tab-facebook .dcsmt-btn, li.active.dcsmt-facebook, li.dcsmt-facebook:hover{background-color:#3b5998;}.tab-fblike,.tab-fblike .dcsmt-btn, li.active.dcsmt-fblike, li.dcsmt-fblike:hover{background-color:#3b5998;}.tab-fbrec,.tab-fbrec .dcsmt-btn, li.active.dcsmt-fbrec, li.dcsmt-fbrec:hover{background-color:#3b5998;}.tab-google,.tab-google .dcsmt-btn, li.active.dcsmt-google, li.dcsmt-google:hover{background-color:#2d2d2d;}.tab-rss,.tab-rss .dcsmt-btn, li.active.dcsmt-rss, li.dcsmt-rss:hover{background-color:#FF9800;}.tab-flickr,.tab-flickr .dcsmt-btn, li.active.dcsmt-flickr, li.dcsmt-flickr:hover{background-color:#f90784;}.tab-delicious,.tab-delicious .dcsmt-btn, li.active.dcsmt-delicious, li.dcsmt-delicious:hover{background-color:#3271CB;}.tab-youtube,.tab-youtube .dcsmt-btn, li.active.dcsmt-youtube, li.dcsmt-youtube:hover{background-color:#DF1F1C;}.tab-digg,.tab-digg .dcsmt-btn, li.active.dcsmt-digg, li.dcsmt-digg:hover{background-color:#195695;}.tab-pinterest,.tab-pinterest .dcsmt-btn, li.active.dcsmt-pinterest, li.dcsmt-pinterest:hover{background-color:#CB2528;}.tab-lastfm,.tab-lastfm .dcsmt-btn, li.active.dcsmt-lastfm, li.dcsmt-lastfm:hover{background-color:#C90E12;}.tab-dribbble,.tab-dribbble .dcsmt-btn, li.active.dcsmt-dribbble, li.dcsmt-dribbble:hover{background-color:#F175A8;}.tab-vimeo,.tab-vimeo .dcsmt-btn, li.active.dcsmt-vimeo, li.dcsmt-vimeo:hover{background-color:#4EBAFF;}.tab-stumbleupon,.tab-stumbleupon .dcsmt-btn, li.active.dcsmt-stumbleupon, li.dcsmt-stumbleupon:hover{background-color:#EB4924;}.tab-deviantart,.tab-deviantart .dcsmt-btn, li.active.dcsmt-deviantart, li.dcsmt-deviantart:hover{background-color:#B8C529;}.tab-tumblr,.tab-tumblr .dcsmt-btn, li.active.dcsmt-tumblr, li.dcsmt-tumblr:hover{background-color:#365472;}.tab-linkedin,.tab-linkedin .dcsmt-btn, li.active.dcsmt-linkedin, li.dcsmt-linkedin:hover{background-color:#006DA7;}.tab-instagram,.tab-instagram .dcsmt-btn, li.active.dcsmt-instagram, li.dcsmt-instagram:hover{background-color:#413A33;}.social-tabs li {background:#777;}@media only screen and (max-width: 400px) {.dcsnt {display: none;}}</style><style type='text/css'>img#wpstats{display:none}</style><link rel="shortcut icon" href="https://bmxultra.com/wp-content/uploads/2013/07/favicon1.png"><meta name="robots" content="noodp,noydir">  <script type="text/javascript">var analyticsFileTypes = [''];
    var analyticsSnippet = 'enabled';
    var analyticsEventTracking = 'enabled';</script> <script type="text/javascript">var _gaq = _gaq || [];
  
	_gaq.push(['_setAccount', 'UA-732058-1']);
    _gaq.push(['_addDevId', 'i9k95']); // Google Analyticator App ID with Google
	_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		                ga.src = 'https://bmxultra.com/wp-content/uploads/cached-scripts/ga.js';
		                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();</script> <style type="text/css" id="wp-custom-css">/*
Welcome to Custom CSS!

To learn how this works, see http://wp.me/PEmnE-Bt
*/
.home .extras .entry-part {
	width: 47%;
}

.home .extras .entry-part h2.entry-title {
	height: unset;
}

@media only screen and (max-width: 1000px) {
	.home .extras .entry-part {
		width: 100%;
		margin-left: 0;
	}
	#subheader-search {
		float: none!important;
	}
}

h2 {
	font-family: "LeagueGothicRegular", Arial, sans-serif;
	text-transform: uppercase;
}

#text-17, #text-4 {
	padding: 10px 0 0 !important;
}

#text-17 h3, #text-4 h3 {
	padding-left: 20px;
}

.ui-widget-header {
	background: #53b7e8;
}

.content-column.one_half {
	width: 49%;
}
.content-column.one_half.last_column {
	padding-left: 2%;
}
label {
    font-weight: 400;
    color: #666;
    font-size: 13px;
    text-transform: unset;
}
@media only screen and (max-width: 600px) {
.content-column.one_half {
	width: 100%;
}
}</style><noscript><style id="rocket-lazyload-nojs-css">.rll-youtube-player, [data-lazy-src]{display:none !important;}</style></noscript></head><body data-rsssl=1 class="post-template-default single single-post postid-34232 single-format-standard mobile-sidebar"><div id="wrap"><header id="header"><div id="header-inner" class="container fix"><h1 id="logo"> <a href="https://bmxultra.com"><img src="https://bmxultra.com/wp-content/themes/feather12/img/bmxultra40.png" alt="bmxultra.com" width="279" height="40" /></a></h1><nav id="header-nav" class="fix"><ul id="nav" class="menu"><li id="menu-item-2032" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-2032"><a href="https://bmxultra.com/">Home</a></li><li id="menu-item-2045" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-2045"><a href="https://bmxultra.com/category/news/">News</a><ul class="sub-menu"><li id="menu-item-8268" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8268"><a href="https://bmxultra.com/category/freestyle-bmx/">Freestyle BMX</a></li><li id="menu-item-4752" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4752"><a href="https://bmxultra.com/news-archive/">News Archive</a></li></ul></li><li id="menu-item-2200" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2200"><a href="https://bmxultra.com/category/photos/">Photos</a><ul class="sub-menu"><li id="menu-item-8087" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8087"><a href="https://bmxultra.com/category/video/">Video</a></li></ul></li><li id="menu-item-2041" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2041"><a href="https://bmxultra.com/category/review/">Reviews</a><ul class="sub-menu"><li id="menu-item-8011" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8011"><a href="https://bmxultra.com/category/review/complete-bikes/">Complete Bikes</a></li><li id="menu-item-8007" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8007"><a href="https://bmxultra.com/category/review/frames/">Frames</a></li><li id="menu-item-8010" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8010"><a href="https://bmxultra.com/category/review/fork-review/">Forks</a></li><li id="menu-item-8008" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8008"><a href="https://bmxultra.com/category/review/bars/">Handlebars</a></li><li id="menu-item-8009" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8009"><a href="https://bmxultra.com/category/review/headstem/">Headstems</a></li><li id="menu-item-8012" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8012"><a href="https://bmxultra.com/category/review/brakes-review/">Brakes</a></li><li id="menu-item-8013" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8013"><a href="https://bmxultra.com/category/review/cranks-review/">Cranks</a></li><li id="menu-item-8014" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8014"><a href="https://bmxultra.com/category/review/grips-review/">Grips</a></li><li id="menu-item-8015" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8015"><a href="https://bmxultra.com/category/review/hubs-review/">Hubs</a></li><li id="menu-item-8016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8016"><a href="https://bmxultra.com/category/review/pedals/">Pedals</a></li><li id="menu-item-8017" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8017"><a href="https://bmxultra.com/category/review/rims-review/">Rims</a></li><li id="menu-item-8018" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8018"><a href="https://bmxultra.com/category/review/seat-review/">Seats</a></li><li id="menu-item-8019" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8019"><a href="https://bmxultra.com/category/review/tires-review/">Tires</a></li><li id="menu-item-8006" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8006"><a href="https://bmxultra.com/category/review/gear/">Race Clothing</a></li><li id="menu-item-8220" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8220"><a href="https://bmxultra.com/category/review/clothing-review/">Casual Clothing</a></li><li id="menu-item-2040" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2040"><a href="https://bmxultra.com/category/review/lifestyle/">Lifestyle</a></li></ul></li><li id="menu-item-3171" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3171"><a href="https://bmxultra.com/category/interview/">Interviews</a></li><li id="menu-item-2658" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2658"><a href="https://bmxultra.com/gear-calculator/">Gear Calculator</a><ul class="sub-menu"><li id="menu-item-30217" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30217"><a href="https://bmxultra.com/gear-calculator/">Gear Calculator</a></li><li id="menu-item-30197" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30197"><a href="https://bmxultra.com/gear-calculator/revlookup/">Reverse Lookup Gear Chart</a></li><li id="menu-item-2657" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2657"><a href="https://bmxultra.com/gear-chart/">Standard Gear Chart</a></li><li id="menu-item-28112" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28112"><a href="https://bmxultra.com/rennen-bmx-decimal-gear-chart/">Decimal Gear Chart</a></li><li id="menu-item-8121" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8121"><a href="https://bmxultra.com/gearcalc/">BMX Gear Calculator App</a></li></ul></li><li id="menu-item-2042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-2042"><a href="https://bmxultra.com/links/">Links</a><ul class="sub-menu"><li id="menu-item-8120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-8120"><a href="https://bmxultra.com/bsx/">BSX</a><ul class="sub-menu"><li id="menu-item-33543" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-33543"><a href="https://bmxultra.com/answer-ssquared-bsx2020/">BSX2020</a></li><li id="menu-item-30414" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-30414"><a href="https://bmxultra.com/bsx2019/">BSX2019</a></li><li id="menu-item-28152" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-28152"><a href="https://bmxultra.com/bsx/bsx2018-charity-event/">BSX2018</a></li><li id="menu-item-25931" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25931"><a href="https://bmxultra.com/bsx/bsx2017/">BSX2017</a></li><li id="menu-item-21496" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21496"><a href="https://bmxultra.com/bsx2016-bmx-charity-event/">BSX2016</a></li><li id="menu-item-21497" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21497"><a href="https://bmxultra.com/bsx/bsx2015/">BSX2015</a></li><li id="menu-item-14152" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-14152"><a href="https://bmxultra.com/bsx/bsx2014/">BSX2014</a></li></ul></li><li id="menu-item-2053" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-2053"><a href="https://bmxultra.com/team/">Team</a></li><li id="menu-item-16621" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16621"><a href="https://bmxultra.com/the-history-of-australian-bmx-racing/">History Of Australian BMX Racing</a></li><li id="menu-item-8150" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8150"><a href="https://bmxultra.com/dirt-2/">Dirt Designs</a></li><li id="menu-item-8155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8155"><a href="https://bmxultra.com/contact-us/">Contact Us</a></li><li id="menu-item-10026" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-10026"><a href="https://bmxultra.com/forum">bmxultra.com forum</a><ul class="sub-menu"><li id="menu-item-8168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-8168"><a href="/smf">The old forum</a></li></ul></li><li id="menu-item-11072" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11072"><a href="https://bmxultra.com/site-map/">Site Map</a></li></ul></li></ul></nav></div></header><div id="subheader"><div class="container fix"><div id="subheader-search" class="fix"><form method="get" id="searchform" action="https://bmxultra.com/"><div> <input type="text" id="s" name="s" onblur="if(this.value=='')this.value='Enter your search...';" onfocus="if(this.value=='Enter your search...')this.value='';" value="Enter your search..." /></div></form></div><ul class="ad"></ul></div></div><div class="pagecontainer container fix "><div id="page-title"><h2>News</h2></div><div id="content-part"><article id="entry-34232" class="entry fix post-34232 post type-post status-publish format-standard has-post-thumbnail hentry category-news"><div class="pad fix"><header class="fix"><h1 class="entry-title"> Product Spotlight: Stay Strong Torque PRO Platform Pedals</h1><ul class="entry-meta fix"><li class="entry-date">May 6th, 2021</li><li class="entry-author"><a href="https://bmxultra.com/author/admin/" title="Posts by bmxultra" rel="author">bmxultra</a></li><li class="entry-comments"><a href="https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/#respond">0</a></li></ul></header><div class="clear"></div><div class="text"><p>Stay Strong started off as a brand to help raise money and show support for seriously injured Stephen Murray, but it&#8217;s become so much more than that. Stay Strong provide a wide range of BMX race specific products including platform pedals.</p><p><img loading="lazy" class="aligncenter size-large wp-image-34233" src="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-640x427.jpg" alt="" width="640" height="427" srcset="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-640x427.jpg 640w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-300x200.jpg 300w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-768x512.jpg 768w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-50x33.jpg 50w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-708x472.jpg 708w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x.jpg 1000w" sizes="(max-width: 640px) 100vw, 640px" /></p><p>Stay Strong&#8217;s Torque Pro pedals offer tremendous grip through a larger platform and long pins. They also offer longevity through sealed bearings and CNC&#8217;d high quality aluminium while only tipping the scales at just 300 grams for the pair.</p><p>Check them out.</p><h2>Manufacturer&#8217;s Description</h2><p>Stay Strong Torque Pro Pedal</p><ul><li>Body: Alloy Extrusion CNC finished</li><li>Design: Super thin &#8211; 10mm design</li><li>Branding: Stay Strong Race DVSN laser etched logos</li><li>Bearings: 2DU</li><li>Size: 100mm x 105mm x 10mm</li><li>Weight: 300g (pair)</li></ul><h2>Gallery</h2><style type="text/css">#gallery-1 {
				margin: auto;
			}
			#gallery-1 .gallery-item {
				float: left;
				margin-top: 10px;
				text-align: center;
				width: 25%;
			}
			#gallery-1 img {
				border: 2px solid #cfcfcf;
			}
			#gallery-1 .gallery-caption {
				margin-left: 0;
			}
			/* see gallery_shortcode() in wp-includes/media.php */</style><div id='gallery-1' class='gallery galleryid-34232 gallery-columns-4 gallery-size-thumbnail'><dl class='gallery-item'><dt class='gallery-icon landscape'> <a href="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L03_1000x.jpg" data-slb-active="1" data-slb-asset="1835463406" data-slb-internal="0" data-slb-group="34232"><img width="150" height="150" src="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L03_1000x-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" loading="lazy" srcset="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L03_1000x-150x150.jpg 150w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L03_1000x-170x170.jpg 170w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L03_1000x-470x470.jpg 470w" sizes="(max-width: 150px) 100vw, 150px" /></a></dt></dl><dl class='gallery-item'><dt class='gallery-icon landscape'> <a href="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L02_1000x.jpg" data-slb-active="1" data-slb-asset="1664463889" data-slb-internal="0" data-slb-group="34232"><img width="150" height="150" src="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L02_1000x-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" loading="lazy" srcset="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L02_1000x-150x150.jpg 150w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L02_1000x-170x170.jpg 170w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L02_1000x-470x470.jpg 470w" sizes="(max-width: 150px) 100vw, 150px" /></a></dt></dl><dl class='gallery-item'><dt class='gallery-icon landscape'> <a href="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x.jpg" data-slb-active="1" data-slb-asset="1209804189" data-slb-internal="0" data-slb-group="34232"><img width="150" height="150" src="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-150x150.jpg" class="attachment-thumbnail size-thumbnail" alt="" loading="lazy" srcset="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-150x150.jpg 150w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-170x170.jpg 170w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-470x470.jpg 470w" sizes="(max-width: 150px) 100vw, 150px" /></a></dt></dl> <br style='clear: both' /></div><h2>Want to know more?</h2><p>Check out the ECI website <a href="http://www.eciimports.com/brand/stay-strong" target="_blank" rel="noopener">www.eciimports.com/brand/stay-strong</a> to see the wide range of Stay Strong products.</p><div style="padding-bottom:10px; padding-top:10px;" class="hupso-share-buttons"><a class="hupso_counters" href="https://www.hupso.com/share/"><img src="https://static.hupso.com/share/buttons/dot.png" style="border:0px; padding-top:2px; float:left;" alt="Share Button"/></a><script type="text/javascript">var hupso_services_c=new Array("twitter","facebook_like","facebook_send","google");var hupso_counters_lang = "en_US";var hupso_image_folder_url = "";var hupso_twitter_via="bmxultra";var hupso_url_c="";var hupso_title_c="Product%20Spotlight%3A%20Stay%20Strong%20Torque%20PRO%20Platform%20Pedals";</script><script type="text/javascript" src="https://static.hupso.com/share/js/counters.js"></script></div><div class="clear"></div></div><div class="post-nav"><div class="prev"> &laquo; <a href="https://bmxultra.com/news/ecitv-video-lilydale-bmx-clubs-conquer-the-valley/" rel="prev">ECITV Video: Lilydale BMX Club&#8217;s &#8220;Conquer the Valley&#8221;</a></div> |<div class="next"> <a href="https://bmxultra.com/news/ecitv-video-bias-opinion-2021-world-tour-episode-1/" rel="next">ECITV Video: Bias Opinion &#8211; 2021 World Tour Episode 1</a> &raquo;</div></div><p class="entry-category"><span>Posted in:</span> <a href="https://bmxultra.com/category/news/" rel="category tag">News</a></p></div></article></div><div id="sidebar" class="sidebar-right"><ul><li id="wp_category_post_list_itg-2" class="widget widget_wp_category_post_list_itg"><h3 class="widget-title"><span>Other News</span></h3><ul class="wp-cpl-widget wp-cpl-theme-no"><li class="wp-cpl wp-cpl-even"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/2021-uci-supercross-r-1-2-verona-italy-schedule-live-video-link/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCBathurst-img_5914-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" loading="lazy" srcset="https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCBathurst-img_5914-50x33.jpg 50w, https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCBathurst-img_5914-300x200.jpg 300w, https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCBathurst-img_5914-640x427.jpg 640w, https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCBathurst-img_5914-768x512.jpg 768w, https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCBathurst-img_5914-1536x1024.jpg 1536w, https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCBathurst-img_5914-708x472.jpg 708w, https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCBathurst-img_5914.jpg 1800w" sizes="(max-width: 50px) 100vw, 50px" /></a></span></span><a href="https://bmxultra.com/news/2021-uci-supercross-r-1-2-verona-italy-schedule-live-video-link/" title="Permalink to: 2021 UCI Supercross R 1 & 2, Verona Italy, Schedule & Live Video Link" target="_self">2021 UCI Supercross R 1 & 2, Verona Italy, Schedule & Live Video Link</a></li><li class="wp-cpl wp-cpl-odd"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/interview-with-tiogas-kai-cheng/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2021/05/kai-cheng-tioga-interview-feature-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="Interview with Tioga&#039;s Kai Cheng" loading="lazy" /></a></span></span><a href="https://bmxultra.com/news/interview-with-tiogas-kai-cheng/" title="Permalink to: Interview with Tioga's Kai Cheng" target="_self">Interview with Tioga's Kai Cheng</a></li><li class="wp-cpl wp-cpl-even"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/ecitv-video-bias-opinion-2021-world-tour-episode-1/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2021/05/bias-youtube-feature-image-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" loading="lazy" /></a></span></span><a href="https://bmxultra.com/news/ecitv-video-bias-opinion-2021-world-tour-episode-1/" title="Permalink to: ECITV Video: Bias Opinion - 2021 World Tour Episode 1" target="_self">ECITV Video: Bias Opinion - 2021 World Tour Episode 1</a></li><li class="wp-cpl wp-cpl-odd"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" loading="lazy" srcset="https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-50x33.jpg 50w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-300x200.jpg 300w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-640x427.jpg 640w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-768x512.jpg 768w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x-708x472.jpg 708w, https://bmxultra.com/wp-content/uploads/2021/05/staystrong-TORQUE_BLACK_L01_1000x.jpg 1000w" sizes="(max-width: 50px) 100vw, 50px" /></a></span></span><a href="https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/" title="Permalink to: Product Spotlight: Stay Strong Torque PRO Platform Pedals" target="_self">Product Spotlight: Stay Strong Torque PRO Platform Pedals</a></li><li class="wp-cpl wp-cpl-even"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/ecitv-video-lilydale-bmx-clubs-conquer-the-valley/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2021/05/lilydale-youtube-feature-image-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" loading="lazy" /></a></span></span><a href="https://bmxultra.com/news/ecitv-video-lilydale-bmx-clubs-conquer-the-valley/" title="Permalink to: ECITV Video: Lilydale BMX Club's "Conquer the Valley"" target="_self">ECITV Video: Lilydale BMX Club's "Conquer the Valley"</a></li><li class="wp-cpl wp-cpl-odd"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/ecitv-100-bmx-racing-show-episode-38-true-believers/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2021/05/ecitv-ep-38-youtube-feature-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" loading="lazy" /></a></span></span><a href="https://bmxultra.com/news/ecitv-100-bmx-racing-show-episode-38-true-believers/" title="Permalink to: ECITV - 100% BMX Racing Show: Episode 38 "True Believers"" target="_self">ECITV - 100% BMX Racing Show: Episode 38 "True Believers"</a></li><li class="wp-cpl wp-cpl-even"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/no-world-champs-for-australians-junior-and-challenge-classes/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCShepp-img_5286-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" loading="lazy" srcset="https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCShepp-img_5286-50x33.jpg 50w, https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCShepp-img_5286-300x200.jpg 300w, https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCShepp-img_5286-640x427.jpg 640w, https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCShepp-img_5286-768x512.jpg 768w, https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCShepp-img_5286-708x472.jpg 708w, https://bmxultra.com/wp-content/uploads/2020/02/202002-UCIWCShepp-img_5286.jpg 1024w" sizes="(max-width: 50px) 100vw, 50px" /></a></span></span><a href="https://bmxultra.com/news/no-world-champs-for-australians-junior-and-challenge-classes/" title="Permalink to: No World Champs for Australian's: Junior and Challenge Classes" target="_self">No World Champs for Australian's: Junior and Challenge Classes</a></li><li class="wp-cpl wp-cpl-odd"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/ten-ways-to-make-your-bike-safer-for-bmx-racing/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2013/05/201302_lilydale_img_1259-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" loading="lazy" srcset="https://bmxultra.com/wp-content/uploads/2013/05/201302_lilydale_img_1259-50x33.jpg 50w, https://bmxultra.com/wp-content/uploads/2013/05/201302_lilydale_img_1259-300x200.jpg 300w, https://bmxultra.com/wp-content/uploads/2013/05/201302_lilydale_img_1259-640x426.jpg 640w, https://bmxultra.com/wp-content/uploads/2013/05/201302_lilydale_img_1259-708x472.jpg 708w, https://bmxultra.com/wp-content/uploads/2013/05/201302_lilydale_img_1259.jpg 1024w" sizes="(max-width: 50px) 100vw, 50px" /></a></span></span><a href="https://bmxultra.com/news/ten-ways-to-make-your-bike-safer-for-bmx-racing/" title="Permalink to: Ten Ways To Make Your Bike Safer For BMX Racing" target="_self">Ten Ways To Make Your Bike Safer For BMX Racing</a></li><li class="wp-cpl wp-cpl-even"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/product-spotlight-supercrosss-secretlabs-mad-scientists-tees/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2021/04/Supercross-SecretLabs-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" loading="lazy" /></a></span></span><a href="https://bmxultra.com/news/product-spotlight-supercrosss-secretlabs-mad-scientists-tees/" title="Permalink to: Product Spotlight: Supercross's "#secretlabs" Mad Scientists Tees" target="_self">Product Spotlight: Supercross's "#secretlabs" Mad Scientists Tees</a></li><li class="wp-cpl wp-cpl-odd"><span class="wp-thumb-overlay"><span class="thumb_lay"><a href="https://bmxultra.com/news/mount-gambier-red-bull-uci-pump-track-world-champs-qualifier/"><img width="50" height="33" src="https://bmxultra.com/wp-content/uploads/2021/04/redbull-pumptrack-50x33.jpg" class="attachment-wp-cpl-post-thumb size-wp-cpl-post-thumb wp-post-image" alt="" loading="lazy" /></a></span></span><a href="https://bmxultra.com/news/mount-gambier-red-bull-uci-pump-track-world-champs-qualifier/" title="Permalink to: Mount Gambier Red Bull UCI Pump Track World Champs Qualifier" target="_self">Mount Gambier Red Bull UCI Pump Track World Champs Qualifier</a></li></ul></li><li id="text-4" class="widget widget_text"><h3 class="widget-title"><span>Advertisement</span></h3><div class="textwidget"><p><br /> <a href="https://t.cfjump.com/45419/b/162545" rel="nofollow noindex"><img style="border: none; vertical-align: middle;" src="https://t.cfjump.com/45419/a/162545" alt="" /></a></p><p><a href="http://pedalinginnovations.com/?referrer=15" target="_blank" rel="noopener"><img loading="lazy" title="Pedaling Innovations" src="https://bmxultra.com/wp-content/uploads/2019/08/pedaling-innovations-v3.png" alt="Pedaling Innovations" width="220" height="220" /></a></p><p></p><p><a href="http://supercrossbmx.com" target="_blank" rel="noopener"><img loading="lazy" title="Supercross BMX" src="https://bmxultra.com/wp-content/uploads/2019/08/supercross-2019-220x220.jpg" alt="Supercross BMX" width="220" height="220" /></a></p><p><a href="https://rizenunlimited.com/" rel="noopener"><img loading="lazy" title="Rizen Race Wear" src="https://bmxultra.com/wp-content/uploads/2019/12/rizen-banner-250x250.jpg" alt="Rizen Race Wear" width="220" height="220" /></a></p><p><a href="https://itunes.apple.com/us/app/bmx-gear-calculator/id665859954?mt=8" target="_blank" rel="noopener"><img loading="lazy" title="bmxultra.com gear calculator for iPhone/iPad" src="https://bmxultra.com/wp-content/uploads/2014/04/bmxultra-bmx-gear-calculator-app-tower-ad-v1_5.jpg" alt="bmxultra.com gear calculator for iPhone/iPad" width="220" height="500" /></a></p></div></li><li id="text-5" class="widget widget_text"><h3 class="widget-title"><span>bmxultra.com Archives</span></h3><div class="textwidget"><p>Are you looking for content from the old bmxultra.com website?</p><p>Don't worry it's not gone. We have just tucked it away for you.</p><p><a href="/archive" class="btn btn-default btn-small">View the archives</a></p></div></li></ul></div></div><div class="clear"></div><footer id="footer" class="fix"><div id="footer-contact"><div class="container fix"><p id="contact-email"><a href="mailto:webmaster@bmxultra.com">webmaster@bmxultra.com</a></p><div class="menu-secondary-navigation-container"><ul id="menu-secondary-navigation" class="menu"><li id="menu-item-8413" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8413"><a href="https://bmxultra.com/contact-us/">Contact Us</a></li><li id="menu-item-8594" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8594"><a href="https://bmxultra.com/bmx-sizing-charts/">BMX Sizing Charts</a></li><li id="menu-item-8411" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8411"><a href="https://bmxultra.com/advertise-with-us/">Advertise With Us</a></li></ul></div></div></div><div id="footer-widgets"><div class="container fix"><li id="text-3" class="widget widget_text"><h3 class="widget-title fix"><span>bmxultra.com Partners</span></h3><div class="textwidget"><div style="text-align: center"> <a href="http://www.alienationbmx.com/" target="_blank" rel="noopener"><img src="https://bmxultra.com/wp-content/uploads/2015/09/alienation.png" alt="Alienation BMX" title="Alienation BMX" height="70" width="200" /></a> <a href="http://www.tiogausa.com/" target="_blank" rel="noopener"><img src="https://bmxultra.com/wp-content/uploads/2015/09/tiogabmx.png" alt="Tioga BMX" title="Tioga BMX" height="70" width="200" /></a> <a href="http://www.supercrossbmx.com.au/" target="_blank" rel="noopener"><img src="https://bmxultra.com/wp-content/uploads/2015/09/supercrossbmx.png" alt="Supercross BMX" title="Supercross BMX" height="70" width="200" /></a> <a href="http://www.profileracing.com/" target="_blank" rel="noopener"><img src="https://bmxultra.com/wp-content/uploads/2018/02/profile-logo.png" alt="Profile Racing" title="Profile Racing" height="70" width="200" /></a> <a href="http://www.odigrips.com/" target="_blank" rel="noopener"><img src="https://bmxultra.com/wp-content/uploads/2018/02/odi-logo.png" alt="ODI Grips" title="ODI Grips" height="70" width="200" /></a> <a href="https://rizenunlimited.com/" target="_blank" rel="noopener"><img src="https://bmxultra.com/wp-content/uploads/2019/12/rizen-logo.png" alt="Rizen Race Wear" title="Rizen Race Wear" height="70" width="200" /></a></div></div></li></div></div><div id="footer-bottom"><div class="container fix"><div class="one-half"><p id="copy">Copyright @2020 bmxultra.com. All rights reserved</p></div><div class="one-half last"> <a id="to-top" href="#"><i class="icon-top"></i></a><ul id="footer-social"><li><a href="http://www.facebook.com/bmxultra" target="_blank"><span class="icon"><img src="https://bmxultra.com/wp-content/themes/feather12/air/modules/social/icons/default/facebook_16.png" alt="Facebook" /></span><span class="icon-title"><i class="icon-pike"></i>Facebook</span></a></li><li><a href="http://www.youtube.com/user/bmxultradotcom" target="_blank"><span class="icon"><img src="https://bmxultra.com/wp-content/themes/feather12/air/modules/social/icons/default/youtube_16.png" alt="YouTube" /></span><span class="icon-title"><i class="icon-pike"></i>YouTube</span></a></li><li><a href="https://twitter.com/bmxultra" target="_blank"><span class="icon"><img src="https://bmxultra.com/wp-content/themes/feather12/air/modules/social/icons/default/twitter_16.png" alt="Twitter" /></span><span class="icon-title"><i class="icon-pike"></i>Twitter</span></a></li></ul></div></div></div></footer></div><style id="skip-link-styles">.skip-link.screen-reader-text {
			border: 0;
			clip: rect(1px,1px,1px,1px);
			clip-path: inset(50%);
			height: 1px;
			margin: -1px;
			overflow: hidden;
			padding: 0;
			position: absolute !important;
			width: 1px;
			word-wrap: normal !important;
		}

		.skip-link.screen-reader-text:focus {
			background-color: #eee;
			clip: auto !important;
			clip-path: none;
			color: #444;
			display: block;
			font-size: 1em;
			height: auto;
			left: 5px;
			line-height: normal;
			padding: 15px 23px 14px;
			text-decoration: none;
			top: 5px;
			width: auto;
			z-index: 100000;
		}</style> <script>( function() {
		var skipLinkTarget = document.querySelector( 'main' ),
			parentEl,
			skipLinkTargetID,
			skipLink;

		// Early exit if a skip-link target can't be located.
		if ( ! skipLinkTarget ) {
			return;
		}

		// Get the site wrapper.
		// The skip-link will be injected in the beginning of it.
		parentEl = document.querySelector( '.wp-site-blocks' ) || document.body,

		// Get the skip-link target's ID, and generate one if it doesn't exist.
		skipLinkTargetID = skipLinkTarget.id;
		if ( ! skipLinkTargetID ) {
			skipLinkTargetID = 'wp--skip-link--target';
			skipLinkTarget.id = skipLinkTargetID;
		}

		// Create the skip link.
		skipLink = document.createElement( 'a' );
		skipLink.classList.add( 'skip-link', 'screen-reader-text' );
		skipLink.href = '#' + skipLinkTargetID;
		skipLink.innerHTML = 'Skip to content';

		// Inject the skip link.
		parentEl.insertAdjacentElement( 'afterbegin', skipLink );
	}() );</script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script> <script defer type='text/javascript' id='wp-polyfill-js-after'>( 'fetch' in window ) || document.write( '<script defer src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script defer src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script defer src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script defer src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script defer src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script defer src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script defer src="https://bmxultra.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4"></scr' + 'ipt>' );
( "objectFit" in document.documentElement.style ) || document.write( '<script defer src="https://bmxultra.com/wp-content/plugins/gutenberg/vendor/object-fit-polyfill.min.5f0c4c73.js?ver=2.3.5"></scr' + 'ipt>' );</script> <script type='text/javascript' id='contact-form-7-js-extra'>var wpcf7 = {"api":{"root":"https:\/\/bmxultra.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};</script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_daca149c46601376ce5db68f3658323c.js?ver=5.4.1' id='contact-form-7-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/comment-reply.min.js?ver=5.7.1' id='comment-reply-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/themes/feather12/js/jquery.jplayer.min.js?ver=2.1.0' id='jplayer-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/themes/feather12/js/jquery.flexslider.min.js?ver=2.1' id='flexslider-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_fde6509fae2cafdb6d97e4a9a60cce66.js?ver=3.0.6' id='mousewheel-js'></script> <script type='text/javascript' id='theme-js-extra'>var objectL10n = {"navigate":"Navigate to ..."};</script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_1421cb5b4b819853d228e93c6919241a.js?ver=1.0' id='theme-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_981422db4650b27c56a3fa25c26a9f2c.js?ver=1.0' id='custom-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/mouse.min.js?ver=1.12.1' id='jquery-ui-mouse-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/accordion.min.js?ver=1.12.1' id='jquery-ui-accordion-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.12.1' id='jquery-ui-menu-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_78f5cb63710f54c5fe2c8d3d7c11c26b.js?ver=38deacd1ac2d0c2e45eeddb4ca670b8b' id='wp-hooks-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_8cf141f35b73a68fe6b670124d60b57b.js?ver=25d905ecdd12145589925269b5825cba' id='wp-i18n-js'></script> <script type='text/javascript' id='wp-i18n-js-after'>wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] }, 'default' );</script> <script type='text/javascript' id='wp-dom-ready-js-translations'>( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );</script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_fc83d5b4f25ddc43e1cdaddc128631a6.js?ver=c2b646f82c64237a528ee84a11d1de0e' id='wp-dom-ready-js'></script> <script type='text/javascript' id='wp-a11y-js-translations'>( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );</script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_9280e64d5123de09c3adb9e811e34a55.js?ver=0cbb3e5ba036a3590573e340a8658c00' id='wp-a11y-js'></script> <script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};</script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.12.1' id='jquery-ui-autocomplete-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/slider.min.js?ver=1.12.1' id='jquery-ui-slider-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.12.1' id='jquery-ui-tabs-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/sortable.min.js?ver=1.12.1' id='jquery-ui-sortable-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/draggable.min.js?ver=1.12.1' id='jquery-ui-draggable-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/droppable.min.js?ver=1.12.1' id='jquery-ui-droppable-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/selectable.min.js?ver=1.12.1' id='jquery-ui-selectable-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.12.1' id='jquery-ui-datepicker-js'></script> <script type='text/javascript' id='jquery-ui-datepicker-js-after'>jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});</script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/resizable.min.js?ver=1.12.1' id='jquery-ui-resizable-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/controlgroup.min.js?ver=1.12.1' id='jquery-ui-controlgroup-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/checkboxradio.min.js?ver=1.12.1' id='jquery-ui-checkboxradio-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/button.min.js?ver=1.12.1' id='jquery-ui-button-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/jquery/ui/dialog.min.js?ver=1.12.1' id='jquery-ui-dialog-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-includes/js/wp-embed.min.js?ver=5.7.1' id='wp-embed-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_50c77713f1855a6b57985225a3bd8cbb.js?ver=2.8.1' id='slb_core-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_f53516b0f2d8c1b468e5a2ba48a5c4af.js?ver=2.8.1' id='slb_view-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_dd5ba77a7cc9dba9f36b61a92f2b11b4.js?ver=2.8.1' id='slb-asset-slb_baseline-base-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_fbd698a78f098e42cdcce135cafad2b9.js?ver=2.8.1' id='slb-asset-slb_default-base-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_1ca46707945a8943609b7c5d27f2b7d1.js?ver=2.8.1' id='slb-asset-item-base-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_f368593be49a63e7ee2dd688589ffa8f.js?ver=2.8.1' id='slb-asset-ui-base-js'></script> <script defer type='text/javascript' src='https://bmxultra.com/wp-content/cache/autoptimize/js/autoptimize_single_9bb2f89ed82f6edacfbb38aca4952bdb.js?ver=2.8.1' id='slb-asset-image-base-js'></script> <script type="text/javascript" id="slb_footer">if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB && SLB.has_child('View.init') ) { SLB.View.init({"ui_autofit":true,"ui_animate":true,"slideshow_autostart":true,"slideshow_duration":"6","group_loop":true,"ui_overlay_opacity":"0.8","ui_title_default":false,"theme_default":"slb_default","ui_labels":{"loading":"Loading","close":"Close","nav_next":"Next","nav_prev":"Previous","slideshow_start":"Start slideshow","slideshow_stop":"Stop slideshow","group_status":"Item %current% of %total%"}}); }
if ( !!window.SLB && SLB.has_child('View.assets') ) { {$.extend(SLB.View.assets, {"1835463406":{"id":34235,"type":"image","internal":true,"source":"https:\/\/bmxultra.com\/wp-content\/uploads\/2021\/05\/staystrong-TORQUE_BLACK_L03_1000x.jpg","title":"staystrong-TORQUE_BLACK_L03_1000x","caption":"","description":""},"1664463889":{"id":34234,"type":"image","internal":true,"source":"https:\/\/bmxultra.com\/wp-content\/uploads\/2021\/05\/staystrong-TORQUE_BLACK_L02_1000x.jpg","title":"staystrong-TORQUE_BLACK_L02_1000x","caption":"","description":""},"1209804189":{"id":34233,"type":"image","internal":true,"source":"https:\/\/bmxultra.com\/wp-content\/uploads\/2021\/05\/staystrong-TORQUE_BLACK_L01_1000x.jpg","title":"staystrong-TORQUE_BLACK_L01_1000x","caption":"","description":""}});} }
/* THM */
if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_baseline',{"name":"Baseline","parent":"","styles":[{"handle":"base","uri":"https:\/\/bmxultra.com\/wp-content\/plugins\/simple-lightbox\/themes\/baseline\/css\/style.css","deps":[]}],"layout_raw":"<div class=\"slb_container\"><div class=\"slb_content\">{{item.content}}<div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><div class=\"slb_controls\"><span class=\"slb_close\">{{ui.close}}<\/span><span class=\"slb_slideshow\">{{ui.slideshow_control}}<\/span><\/div><div class=\"slb_loading\">{{ui.loading}}<\/div><\/div><div class=\"slb_details\"><div class=\"inner\"><div class=\"slb_data\"><div class=\"slb_data_content\"><span class=\"slb_data_title\">{{item.title}}<\/span><span class=\"slb_group_status\">{{ui.group_status}}<\/span><div class=\"slb_data_desc\">{{item.description}}<\/div><\/div><\/div><div class=\"slb_nav\"><span class=\"slb_prev\">{{ui.nav_prev}}<\/span><span class=\"slb_next\">{{ui.nav_next}}<\/span><\/div><\/div><\/div><\/div>"}); }if ( !!window.SLB && SLB.has_child('View.extend_theme') ) { SLB.View.extend_theme('slb_default',{"name":"Default (Light)","parent":"slb_baseline","styles":[{"handle":"base","uri":"https:\/\/bmxultra.com\/wp-content\/plugins\/simple-lightbox\/themes\/default\/css\/style.css","deps":[]}]}); }})})(jQuery);}</script> <script type="text/javascript" id="slb_context">if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}</script> <script src='https://stats.wp.com/e-202118.js' defer></script> <script>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.7',blog:'76802680',post:'34232',tz:'10',srv:'bmxultra.com'} ]);
	_stq.push([ 'clickTrackerInit', '76802680', '34232' ]);</script> </body></html>
<!-- *´¨)
     ¸.•´¸.•*´¨) ¸.•*¨)
     (¸.•´ (¸.•` ¤ Comet Cache is Fully Functional ¤ ´¨) -->

<!-- Cache File Version Salt:       n/a -->

<!-- Cache File URL:                https://bmxultra.com/news/product-spotlight-stay-strong-torque-pro-platform-pedals/ -->
<!-- Cache File Path:               /cache/comet-cache/cache/https/bmxultra-com/news/product-spotlight-stay-strong-torque-pro-platform-pedals.html -->

<!-- Cache File Generated Via:      HTTP request -->
<!-- Cache File Generated On:       May 8th, 2021 @ 8:21 am UTC -->
<!-- Cache File Generated In:       2.87223 seconds -->

<!-- Cache File Expires On:         May 15th, 2021 @ 8:21 am UTC -->
<!-- Cache File Auto-Rebuild On:    May 15th, 2021 @ 8:21 am UTC -->

<!-- Loaded via Cache On:    May 8th, 2021 @ 9:13 am UTC -->
<!-- Loaded via Cache In:    0.02794 seconds -->